PC Aviator Inc :: Flight Sim X Addons :: Aircraft :: General Aviation :: Carenado Beechcraft Mentor T34B (FSX/P3D)

Carenado Beechcraft Mentor T34B (FSX/P3D)

Carenado Beechcraft Mentor T34B (FSX/P3D)

Carenado Beechcraft Mentor T34B (FSX/P3D)

Details
SKU DL-CART34X3
COMPATIBILITY FSX/FSX:SE/P3D v3, v4
MEDIA INSTANT DOWNLOAD
SIZE (Mb) 37
PUBLISHER Carenado (MORE)
 
Price: $19.95
Options
Delivery Options
Quantity 1 (this product is an instant download)

Features

  • Full FSX, P3D v2, v3, v4, and Steam compatible.
  • Polygon optimized model
  • Tandem seating trainer
  • Registration N9220T and NAVY 0256
  • Amazing aerobatic model with many details and realistic textures
  • Full moving parts: moving pilot, full animated cockpit doors and cargo, ailerons, elevators, rudders, flaps, rolling wheels, smoke effects
  • Realistic nightlight effects on cockpit
  • Many details as: pitot pressure chamber, antennas, cargo compartment objects
  • Realistic textures and original Mentor paint design
  • Custom panel and gauges
  • Old IFR certification (ADF) and VFR
  • Nightlight effects on panel
  • Similar behavior compared with the real airplane
  • Real weight and balance
Included in the package:
  • 3 paint schemes: Metallic, Navy and FAE
  • 2 models: two and three blades
  • Normal and Emergency Checklist
  • Panel Info
  • Performance tables

Technical Requirements

  • Windows: 10 / 8 / 7 / Vista / XP.
  • Microsoft Flight Simulator FSX with SP1 and SP2 (or Acceleration Pack) installed or Lockheed Martin - Prepar3D Flight Simulator v3 or v4 or FSX Steam Edition.
  • Pentium V/2GHz or similar – 1GB RAM – 128MB graphics card
  • 83 MB hard disk space available
  • INTERNET CONNECTION is required for installing this product

***FREE UPGRADE - If you purchased "Carenado Beechcraft Mentor T34B (FSX)" from PC Aviator you are entitled to a free upgrade.  Please email [email protected] for a coupon code making the update free.  If you are on PC Aviator's email list we will automatically send you the details.  No code is needed if purchased after November 30, 2017

 
-->